Вопрос по информатике:
1. Проверьте, является ли произведение четырёх случайных чисел, чётным числом. Составьте программу.
2. Ввести двузначное число, если сумма цифр чётная, то увеличить число на 2, в противном случае уменьшить на два.
- 22.11.2017 06:02
- Информатика
- remove_red_eye 5742
- thumb_up 20
Ответы и объяснения 1
Program abc321;
var a, b, c, d, e: integer;
begin
write('Введите a:');
readln(a);
write('Введите b:');
readln(b);
write('Введите c:');
readln(c);
write('Введите d:');
readln(d);
e := a * b * c * d;
if (e mod 2 = 0) then writeln('Произведение является четным числом.') else writeln('Произведение является нечетным числом.')
end.
Вот 2 задача:
Program abc123;
var a, b, c: integer;
begin
write('Vvedite dvuznachnoe chislo: ');
readln(a);
b := a div 10;
c := a mod 10;
if ((b + c) mod 2 = 0) then a := a + 2 else a := a - 2; writeln('a := ', a);
end.
- 23.11.2017 12:45
- thumb_up 28
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.