Вопрос по информатике:
Помогите написать программы..
Задача 1
Напишите программу, умеющую проверить положительное ли число, введённое с клавиатуры
Задача 2
Напишите программу в которой из двух введенных с клавиатуры чисел, большее из них выведется на экран
Задача 3
Напишите программу которая при вводе пяти чисел вычисляла бы их сумму и произведение, и выводила на экран, что из этого больше.
- 01.10.2017 08:30
- Информатика
- remove_red_eye 13878
- thumb_up 46
Ответы и объяснения 1
Var x: real;
Begin
writeln ('Введите число');
readln (x);
if x>0 then
writeln ('Число ', x, ' положительное')
else
if x<0 then
writeln ('Число ', x, ' отрицательное')
else
if x=0 then
writeln ('Число ', x, ' не является ни положительным, ни отрицательным');
End.
2.
Var x, y: real;
Begin
writeln ('Введите два числа');
readln (x,y);
if x>y then writeln (x)
else
if x
if x=y then writeln ('Числа равны');
End.
3.
Var x, sum, pr: real;
i: integer;
Begin
sum:=0;
pr:=1;
For i:=1 to 5 do
begin
write ('Введите число: ');
readln (x);
sum:=sum+x;
pr:=pr*x;
end;
writeln ('Сумма чисел = ', sum);
writeln ('Произведение чисел = ', pr);
if sum>pr then writeln (sum)
else
if sum
if sum=pr then writeln ('Сумма и произведение равны');
End.
- 02.10.2017 14:18
- thumb_up 21
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.