Вопрос по информатике:
PASCAL ABC!!!
Дана последовательность натуральных чисел, завершающаяся число 0. Определите наибольшую длину монотонного фрагмента последовательности (то есть такого фрагмента, где все элементы либо больше предыдущего, либо меньше).
Числа, следующие за числом 0, считывать не нужно.
- 20.12.2017 15:15
- Информатика
- remove_red_eye 9587
- thumb_up 8
Ответы и объяснения 1
Begin
Max:=1;
Read(A);
B:=A;
Repeat
if A>B then
Begin
if k>Max then Max:=k;
k:=1;
While (A>B)and(A>0) do
Begin
k:=k+1;
B:=A;
Read(A);
End;
End;
if A Begin
if k>Max then Max:=k;
k:=1;
While (A0) do
Begin
k:=k+1;
B:=A;
Read(A);
End;
End;
if A=B then
Begin
if k>Max then Max:=k;
k:=1;
B:=A;
Read(A);
End;
Until A=0;
if k>Max then Write(k)
else Write(Max)
End.
- 21.12.2017 16:23
- thumb_up 41
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.