Вопрос по информатике:
Написать программу удаления половины символов, зная, что количество символов в строке - чётное. (Паскаль)
- 25.08.2018 21:25
- Информатика
- remove_red_eye 19891
- thumb_up 36
Ответы и объяснения 2
Var
S:string;
Begin
Write('Введите строку: ');ReadLn(S);
S:=Copy(S,1,Length(S) div 2);
WriteLn(S);
End.
Пример работы программы:
Введите строку: 1234
12
Для удаления левой половины символов:
Var
S:string;
Begin
Write('Введите строку: ');ReadLn(S);
S:=Copy(S,Length(S) div 2+1, Length(S));
WriteLn(S);
End.
Пример работы программы:
Введите строку: 1234
34
Удаление выбранной половины символов:
Var
S:string;
A:byte;
Begin
Write('Введите строку: ');ReadLn(S);
WriteLn('1 - удаление правой половины, 2 - удаление левой половины');
ReadLn(A);
if A = 1 then S:=Copy(S,Length(S) div 2+1, Length(S))
else S:=Copy(S,1,Length(S) div 2);
WriteLn(S);
End.
Пример работы программы:
Введите строку: 1234567890
1 - удаление правой половины, 2 - удаление левой половины
2
12345
- 26.08.2018 09:46
- thumb_up 20
// PascalABC.NET 3.2, сборка 1429 от 28.04.2017
// Внимание! Если программа не работает, обновите версию!
begin
var s:=ReadlnString;
s:=s.Left(s.Length div 2);
s.Println
end.
Пример
Половину удалим!
Половину
2. Школьный вариант
var
s:string;
n:integer;
begin
Readln(s);
n:=Length(s) div 2;
Delete(s,n+1,n);
Writeln(s);
end.
- 27.08.2018 14:27
- thumb_up 50
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.