Вопрос по информатике:
9 класс
Циклическое программирование
1.Составьте программу которая вычисляет сумму натуральных чисел кратных 4 в диапазоне от 5 до 45
2.Найти сумму нечетных чисел от 79 до 205
3.Найти значение функции на отрезке [1;10] с шагом 0,5
- 21.11.2015 02:54
- Информатика
- remove_red_eye 9665
- thumb_up 7
Ответы и объяснения 1
Var S,A:integer;
Begin
S:=0;
For A:= 5 to 45 do
if A mod 4 = 0 then S:=S+A;
WriteLn('S = ',S);
End.
Результат работы программы:
S = 260
Вторая программа:
Var A,S:integer;
Begin
S:=0;
For A:= 79 to 205 do
if A mod 2 0 then S:=S+A;
WriteLn('S = ',S);
End.
Результат работы программы:
S = 9088
Третья программа:
Var
x:byte;
Begin
WriteLn('f(x) = x^2');
For x:= 1 to 20 do
WriteLn('f(',x/2:3,') = ',Sqr(x/2))
End.
Результат работы программы:
f(x) = x^2
f(0.5) = 0.25
f( 1) = 1
f(1.5) = 2.25
f( 2) = 4
f(2.5) = 6.25
f( 3) = 9
f(3.5) = 12.25
f( 4) = 16
f(4.5) = 20.25
f( 5) = 25
f(5.5) = 30.25
f( 6) = 36
f(6.5) = 42.25
f( 7) = 49
f(7.5) = 56.25
f( 8) = 64
f(8.5) = 72.25
f( 9) = 81
f(9.5) = 90.25
f( 10) = 100
- 22.11.2015 16:56
- thumb_up 40
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.