Вопрос по информатике:
Составить программу в Pascal:
Найти все трехзначные числа, обладающие следующими свойствами:
- сумма цифр числа А делится на 4;
- сумма цифр числа А+2 также делится на 4
- 01.08.2018 03:10
- Информатика
- remove_red_eye 14470
- thumb_up 36
Ответы и объяснения 1
begin
for i1:=100 to 997 do
begin
s1:=(i1 div 100)+(i1 div 10 mod 10)+(i1 mod 10);
i2:=i1+2;
s2:=(i2 div 100)+(i2 div 10 mod 10)+(i2 mod 10);
if (s1 mod 4=0)and(s2 mod 4=0) then writeln(i1,' ',i2);
end;
end.
Результат:
299 301
398 400
699 701
798 800
- 02.08.2018 20:27
- thumb_up 25
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.