Вопрос по информатике:
Напишите программу, которая в последовательности натуральных чисел определяет сумму и количество чисел нечетных чисел кратных 5. Программа получает на вход количество чисел в последовательности, а затем сами числа. Программа должна вывести два числа количество и сумму нечетных чисел кратных 5.
- 09.02.2018 03:48
- Информатика
- remove_red_eye 8901
- thumb_up 35
Ответы и объяснения 1
A,k,n:integer;
S:real;
Begin
S:=0;
k:=0;
Write('n = ');ReadLn(n);
For n:= 1 to n do
Begin
Read(A);
if (A mod 5 = 0)and(A mod 2 0) then
Begin
S:=S+A;
k:=k+1
End;
End;
WriteLn('k = ',k);
WriteLn('S = ',S);
End.
Пример работы программы:
n = 7
5
15
95
97
90
98
0
k = 3
S = 115
- 01.01.1970 00:00
- thumb_up 2
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.