Вопрос по информатике:
Даны два натуральных числа. Вычислите их наибольший общий делитель при помощи алгоритма Евклида, реализованного без использования рекурсии.
Входные данные
Вводится два натуральных числа.
Выходные данные
Выведите ответ на задачу.
Примеры
входные данные
12
14
выходные данные
2
- 15.05.2016 00:30
- Информатика
- remove_red_eye 13068
- thumb_up 21
Ответы и объяснения 1
// Внимание! Если программа не работает, обновите версию!
begin
var a,b:integer;
Read(a,b);
while b0 do begin a:=a mod b; Swap(a,b) end;
Writeln(a);
end.
- 15.05.2016 12:15
- thumb_up 26
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.