Вопрос по информатике:
Дано целое положительное трехзначное число n. Составить программу ,которая определяет входит ли в него цифра 8.
- 03.09.2018 06:10
- Информатика
- remove_red_eye 16938
- thumb_up 28
Ответы и объяснения 1
Begin
Write('Введите трёхзначное число: ');ReadLn(n);
n:=Abs(n);
if (n div 100 = 8)or((n div 10) mod 10 = 8)or(n mod 10 = 8) then WriteLn('Входит')
else WriteLn('Не входит')
End.
Пример работы программы:
Введите трёхзначное число: 85
Входит
- 04.09.2018 05:30
- thumb_up 46
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.