Вопрос по информатике:
Составить программы для заданий 3 – 5
3. Найти сумму чётных чисел из натурального ряда от 1 до 1000?
4. Дано Nчисел. Написать программу, находящую номер самого большого числа.
5. В кассе имеются купюры достоинством в К рублей и 1 рубль. Выдать N рублей минимальным набором купюр заданного достоинства.
Помогите кому не сложно (
- 09.10.2017 15:19
- Информатика
- remove_red_eye 1742
- thumb_up 5
Ответы и объяснения 1
Var S,i:integer;
Begin
S:=0;
For i:= 1 to 1000 do
if i mod 2 = 0 then S:=S+i;
WriteLn('S = ',S)
End.
Результат работы программы:
S = 250500
4.
Var
N,A,i,Max:integer;
Begin
Write('N = ');ReadLn(N);
Write('Введите целые числа(',N,' шт.):');
Read(Max);
i:=1;
For N:= 2 to N do
Begin
Read(A);
if A > Max then
Begin
Max:=A;
i:=N
End;
End;
WriteLn('Максимум: ',Max);
WriteLn('Номер максимума: ',i);
End.
Пример работы программы:
N = 7
Введите целые числа(7 шт.):1 2 3 5 9 4 7
Максимум: 9
Номер максимума: 5
5.
Var K,N:integer;
Begin
Write('K = ');ReadLn(K);
Write('N = ');ReadLn(N);
WriteLn('Количество купюр по ',K,' руб.: ',N div K);
WriteLn('Количество купюр по 1 рублю: ',N mod K);
End.
Пример работы программы:
K = 38
N = 3000
Количество купюр по 38 руб.: 78
Количество купюр по 1 рублю: 36
- 01.01.1970 00:00
- thumb_up 24
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.