Вопрос по информатике:
Составьте программу. Для вводимых с клавиатуры чисел определить количество положительных. ввод чисел прекращается, когда пользователь вводит 0.
- 22.04.2018 20:50
- Информатика
- remove_red_eye 8924
- thumb_up 31
Ответы и объяснения 1
begin
writeln('Вводите числа. Конец ввода - 0');
k:=0;
readln(a);
while a0 do
begin
if a>0 then k:=k+1;
readln(a);
end;
writeln('k = ',k);
end.
Пример:
Вводите числа. Конец ввода - 0
8
-4
5
-2
3
-7
0
k = 3
- 23.04.2018 13:50
- thumb_up 48
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.