Вопрос по информатике:
Помогите написать программу в Паскаль.
Сформировать массив, подметить кол-во отрицательных элементов и заменить их на 2
- 21.06.2018 13:00
- Информатика
- remove_red_eye 17285
- thumb_up 44
Ответы и объяснения 1
N = 13;
Var
A:array[1..N] of integer;
i,k:integer;
Begin
Randomize;
k:=0;
Write('Исходный массив:');
For i:= 1 to N do
Begin
A[i]:=random(21)-10;
Write(' ',A[i]);
if A[i] < 0 then
Begin
k:=k+1;
A[i]:=2
End;
End;
WriteLn;
WriteLn('Количество отрицательных элементов: ',k);
Write('Новый массив:');
For i:= 1 to N do
Write(' ',A[i])
End.
Пример работы программы:
Исходный массив: -1 -9 7 -2 -5 -3 -1 6 3 -6 9 8 -10
Количество отрицательных элементов: 8
Новый массив: 2 2 7 2 2 2 2 6 3 2 9 8 2
- 22.06.2018 18:00
- thumb_up 47
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.