Вопрос по информатике:
Помогите написать программу в Паскале.
Дан массив размера N.
1. Найти количество участков К, на которых его элементы монотонно возрастают.
- 14.11.2017 22:04
- Информатика
- remove_red_eye 7712
- thumb_up 31
Ответы и объяснения 1
var a:array[1..n] of integer;
i,k,m:integer;
begin
Randomize;
writeln('Массив A:');
for i:=1 to n do
begin
a[i]:=random(51);
write(a[i]:3);
end;
writeln;
k:=0; m:=0;
for i:=1 to n-1 do
begin
if a[i+1]>a[i] then begin m:=m+1; end
else begin if m>0 then k:=k+1; m:=0; end;
end;
if m>0 then k:=k+1;
writeln('k = ',k);
end.
Пример:
Массив A:
7 30 22 0 17 4 2 32 39 26 23 41 1 38 47 21 38 31 43 7
k = 7
- 15.11.2017 03:11
- thumb_up 3
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.