Вопрос по информатике:
Сколько различных значений числа d можно ввести, чтобы после выполнения программы было напечатано 69?
var n, s, d: integer;
begin
readln(d);
n := 14;
s := 29;
while s <= 2000 do begin
s := s + d;
n := n + 5
end;
write(n)
end.
- 10.12.2015 14:17
- Информатика
- remove_red_eye 3938
- thumb_up 8
Ответы и объяснения 1
Из программы видно, что 14+k*5 = 69 => k = 11
29 + k*d >= 2000, отсюда получаем минимальное значение d
d = 1971/11 = 179,18 , но так как d - целое, то d min = 180.
Максимальное значение d из условия: d max = (1999-29)/10 = 197
- 11.12.2015 04:57
- thumb_up 41
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.