Вопрос по информатике:
Помогите написать программу по программированию
Напишите программу которая в последовательности целых чисел определяет количество чисел оканчивающихся на 5 или кратных 3.Программа получает на вход целое числа количество введённых чисел неизвестно последовательность заканчивается числом 0 (0-признак окончание ввода, не входит в последовательность)
Количество чисел не превышает 1000.Введённые числа по модулю не превышают 30000.
Программа должна вывести одно число: количество чисел оканчивающихся на 5 или кратно 3.
- 03.09.2016 23:58
- Информатика
- remove_red_eye 10227
- thumb_up 42
Ответы и объяснения 1
Begin
k:=-1;
Repeat
Read(A);
if (Abs(A) mod 10 = 5)or(A mod 3 = 0) then k:=k+1;
Until A = 0;
Write(k)
End.
- 04.09.2016 12:48
- thumb_up 6
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.