Вопрос по информатике:
Написать программу заполнения массива из 50 элементов случайными числами в диапазоне от -50 до 50 найдите количество элементов которые имеют чётное значение и не делятся на три
- 26.10.2017 09:37
- Информатика
- remove_red_eye 18569
- thumb_up 50
Ответы и объяснения 1
// Внимание! Если программа не работает, обновите версию!
begin
var a:=ArrRandom(50,-50,50); a.Println;
Writeln('k=',a.Where(x->x.IsEven and (x mod 30)).Count)
end.
Пример
46 39 16 14 -16 -35 -34 -38 5 16 -13 -19 48 18 -33 -37 3 -41 46 38 15 21 50 50 21 -29 -34 4 -31 -18 31 -2 26 45 -8 1 13 29 -35 -46 25 -38 -13 23 14 -17 -30 35 9 -34
k=20
- 27.10.2017 14:39
- thumb_up 3
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.