Вопрос по информатике:
Напишите программу, которая в последовательности натуральных чисел определяет минимальное число, делящееся нацело на 7.
Программа получает на вход количество чисел в последовательности, а затем сами числа. В последовательности всегда имеется число, делящееся нацело на 7.
Количество чисел не превышает 1000. Введенные числа не превышают 30 000.
Программа должна вывести одно число - минимальное число, делящееся нацело на 7.
Входные данные:
3
11
14
77
Выходные данные:
14
Программу надо на Паскале.
- 16.07.2018 01:24
- Информатика
- remove_red_eye 7840
- thumb_up 5
Ответы и объяснения 2
Begin
Min:=30001;
Read(N);
For N:= 1 to N do
Begin
Read(A);
if (A mod 7 = 0)and(A < Min) then Min:=A;
End;
Write(Min)
End.
- 17.07.2018 06:52
- thumb_up 39
begin
readln(n);
min:=30000;
for i:=1 to n do
begin
readln(a);
if (a mod 7=0)and(a
writeln(min);
end.
Пример:
3
11
14
77
14
- 18.07.2018 16:20
- thumb_up 19
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.