Вопрос по информатике:
Помогите пожалуйста написать программу.(Информатика)
1)Элементы заданного массива X = (x1 , x2, ...,xN ) переупорядочите следующим образом: X = (xN , xN-1 , ..., x1 ).
- 03.01.2016 12:30
- Информатика
- remove_red_eye 6043
- thumb_up 49
Ответы и объяснения 1
a: array[1..100] of integer;
begin
write('n = '); readln(n);
randomize;
writeln('исходный массив:');
for i:=1 to n do
begin
a[i]:=random(100)-50;
write(a[i],' ');
end;
writeln;
writeln('новый массив:');
for i:=1 to n div 2 do
begin
k:=a[i];
a[i]:=a[n-i+1];
a[n-i+1]:=k;
end;
for i:=1 to n do write(a[i],' ');
end.
n = 10
исходный массив:
45 -29 -25 12 -38 5 15 16 47 -36
новый массив:
-36 47 16 15 5 -38 12 -25 -29 45
- 04.01.2016 22:10
- thumb_up 9
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.