Вопрос по информатике:
Очень нужна помощь с Паскалем!
Напишите программу, которая получает три числа и выводит количество одинаковых чисел в этой цепочке.
Входные данные
Входная строка содержит три целых числа, разделённых пробелами.
Выходные данные
Программа должна вывести количество одинаковых чисел из переданного ей набора или число 0, если все числа различные.
- 12.09.2018 00:48
- Информатика
- remove_red_eye 12506
- thumb_up 19
Ответы и объяснения 1
a,b,c,k:integer;
Begin
k:=1;
Read(a,b,c);
if a=b then k:=k+1;
if b=c then k:=k+1;
if c=a then k:=k+1;
if k=1 then k:=0
else
if k=4 then k:=3;
Write(k)
End.
- 13.09.2018 16:22
- thumb_up 15
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.