Вопрос по информатике:
Написать программу , которая выводит целые числа в промежутке от до 50 , кратные восьми и считает их количество , сумму и произведение .
Пожалуйста помоги мне быстрее
- 01.04.2018 02:16
- Информатика
- remove_red_eye 12086
- thumb_up 44
Ответы и объяснения 1
begin
k:=0; s:=0; p:=1;
for i:=1 to 50 do
if i mod 8 = 0 then
begin
write(i,' ');
k:=k+1;
s:=s+i;
p:=p*i;
end;
writeln;
writeln('k = ',k,' s = ',s,' p = ',p);
end.
Результат:
8 16 24 32 40 48
k = 6 s = 168 p = 188743680
- 02.04.2018 14:11
- thumb_up 44
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.