Вопрос по информатике:
Помогите пожалуйста написать программу в паскале. Дано ФИО, например "Петров Иван Андреевич", в итоге программа должна вывести - Петров И.А.
- 03.09.2018 12:12
- Информатика
- remove_red_eye 2751
- thumb_up 6
Ответы и объяснения 2
S,S1:string;
i:integer;
Begin
Write('Введите ФИО: ');
ReadLn(S);
i:=1;
While S[i]' ' do
i:=i+1;
For i:= 1 to i+1 do
S1:=S1+S[i];
S1:=S1+'.';
While S[i]' ' do
i:=i+1;
S1:=S1+S[i+1]+'.';
WriteLn(S1);
End.
- 04.09.2018 03:21
- thumb_up 24
n,m: integer;
begin
write('ФИО: '); readln(s);
n:=pos(' ',s);
s[n]:='*';
m:=pos(' ',s);
s:=copy(s,1,n+1)+'.'+s[m+1]+'.';
s[n]:=' ';
writeln(s);
end.
ФИО: Петров Сидор Иванович
Петров С.И.
- 05.09.2018 04:28
- thumb_up 51
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.