Вопрос по информатике:
На вход программе подаётся последовательность символов, заканчивающаяся точкой. Требуется написать программу, которая определяет, есть ли в этой последовательности цифры, и выводит НАИБОЛЬШЕЕ число, которое можно составить из этих цифр. Ведущих нулей быть не должно, за исключением одного нуля. Если числа нет, выводится сообщение 'no', если число есть - 'да' и в следующей строке искомое число.
Например, если исходная последовательность была такая: Day 10, mice 8: "Year" 7 is a mistake 91.
То результат должен быть следующий:
Да
987110
- 04.09.2018 19:50
- Информатика
- remove_red_eye 1684
- thumb_up 39
Ответы и объяснения 2
var s := readstring();
if(s.Any(x -> x.isDigit)) then
begin
if(s.Any(x->x in['1'..'9'])) then
s.Where(x -> x.IsDigit).OrderByDescending(x -> x).Println
else
write(0);
end
else
writeln('No');
end.
- 05.09.2018 08:51
- thumb_up 48
A:array['0'..'9'] of longint;
C:char;
i:integer;
Begin
For C:= '0' to '9' do A[C]:=0;
Repeat
Read(C);
if C in['0'..'9'] then A[C]:=A[C]+1;
Until C = '.';
if (A['1']=0)and(A['2']=0)and(A['3']=0)and(A['4']=0)and(A['5']=0)and(A['6']=0)and(A['7']=0)and(A['8']=0)and(A['9']=0) then
if A['0']=0 then Write('no')
else
Begin
WriteLn('Да');
WriteLn(0);
End
else
Begin
WriteLn('Да');
For C:='9' downto '0' do
For i:= 1 to A[C] do
Write(C)
End
End.
- 06.09.2018 11:37
- thumb_up 7
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.