Вопрос по информатике:
Напишите программу, которая находит сумму, произведение и среднее арифметическое трех целых чисел, введенных с клавиатуры. Например при вводе чисел 4, 5 и 7мы должны получить ответ 4+5+7=16, 4*5*7=140, ( 4+5+7)/3=5.333333..
- 26.07.2018 20:05
- Информатика
- remove_red_eye 4956
- thumb_up 11
Ответы и объяснения 1
a,b,c:integer;
Begin
Write('Введите три числа: ');ReadLn(a,b,c);
if b<0 then Write(a,b)
else Write(a,'+',b);
if c<0 then Write(c,' = ',a+b+c)
else Write('+',c,' = ',a+b+c);
WriteLn;
if b<0 then Write(a,'*(',b,')')
else Write(a,'*',b);
if c<0 then Write('*(',c,') = ',a*b*c)
else Write('*',c,' = ',a*b*c);
WriteLn;
if b<0 then Write('(',a,b)
else Write('(',a,'+',b);
if c<0 then Write(c,')/3 = ',(a+b+c)/3)
else Write('+',c,')/3 = ',(a+b+c)/3);
End.
- 27.07.2018 14:19
- thumb_up 22
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.