Вопрос по информатике:
Напишите программу,которая в последовательности натуральных чисел находит среднее арифметическое трехзначных чисел или сообщает,что таких чисел нет (выводит NO).программа получает на вход натуральные числа,количество введенных чисел=5.Программа должна вывести среднее арифметическое трехзначных чисел или вывести NO ,если таких чисел нет
- 12.08.2018 15:18
- Информатика
- remove_red_eye 16711
- thumb_up 15
Ответы и объяснения 1
using namespace std;
int main() {
int sum = 0, c = 0;
for(int i = 0, a; i < 5; i++) {
cin >> a;
if(a > 99 && a < 1000) {
sum+=a;
c++;
}
}
cout << (c == 0 ? "NO" : (double)sum/c) << endl;
}
- 14.08.2018 00:27
- thumb_up 3
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.