Вопрос по информатике:
Помогите написать программу в паскале
В массиве А (15) целых чисел поменять местами 5 и 13 элементы. Вывести начальный и изменены массивы в строку через два пробела.
- 03.01.2016 08:53
- Информатика
- remove_red_eye 14558
- thumb_up 39
Ответы и объяснения 2
// Внимание! Если программа не работает, обновите версию!
begin
var a:=ArrRandom(15,-50,50); a.Println(' ');
Swap(a[4],a[12]); // индексы от нуля
a.Println(' ')
end.
Пример
40 28 18 1 35 -50 13 17 40 7 -48 46 -12 -9 50
40 28 18 1 -12 -50 13 17 40 7 -48 46 35 -9 50
- 04.01.2016 12:03
- thumb_up 18
const
n = 15;
var
arr: array[1..n] of integer;
t : integer;
begin
for t := 1 to n do begin
arr[t] := random(101);
write(arr[t], ' ');
end;
writeln();
t := arr[5];
arr[5] := arr[13];
arr[13] := t;
for t := 1 to n do begin
write(arr[t], ' ');
end;
end.
- 05.01.2016 10:32
- thumb_up 6
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.