Вопрос по информатике:
Напишите программу в Дельфи которая переводит число из десятичной в факториальную систему счисления.
- 15.06.2018 09:33
- Информатика
- remove_red_eye 7075
- thumb_up 7
Ответы и объяснения 1
var n,k,i:integer; m,f:string;
begin
write('n = ');
readln(n);
k:=n;
f:='';
i:=1;
while k>0 do
begin
i:=i+1;
str(k mod i,m);
f:=m+f;
k:= k div i;
end;
writeln('f = ',f);
end.
Пример:
n = 100
f = 4020
- 16.06.2018 08:42
- thumb_up 34
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.