Вопрос по информатике:
Последовательностью Фибоначчи называется последовательность чисел a0, a1, ..., an, ..., где a0 = 0, a1 = 1, ak = ak-1 + ak-2 (k > 1).
Требуется найти N-е число Фибоначчи.
Примечание. В программе запрещается использовать циклы.
Формат входных данных
На вход программы поступает целое неотрицательное число N (N ≤ 30).
Формат выходных данных
Требуется вывести N-е число Фибоначчи.
Пример
Входные данные
7
Выходные данные
13
- 12.10.2017 19:36
- Информатика
- remove_red_eye 9581
- thumb_up 37
Ответы и объяснения 1
function Fib(k:integer):integer;
begin
if k=0 then Fib:=0
else if k=1 then Fib:=1
else Fib:=Fib(k-1)+Fib(k-2);
end;
begin
readln(n);
writeln(Fib(n));
end.
Пример:
10
55
- 13.10.2017 02:23
- thumb_up 46
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.