Вопрос по информатике:
С клавиатуры вводится строка состоящая из отдельных слов, разделенных между собой произвольным количеством пробелов. Написать программу оставляющую между словами по 1 пробелу. Помогите пожалуйста
- 07.04.2016 03:49
- Информатика
- remove_red_eye 5266
- thumb_up 47
Ответы и объяснения 1
s,s1:string;
i:integer;
begin
writeln ('Введите строку.');
readln (s);
s1:='';
for i:= 1 to length(s)-1 do
begin
if s[i] ' ' then s1:=s1+s[i];
if (s[i] = ' ')and(s[i+1] ' ') then s1:=s1+s[i];
end;
s:='';
if s1[1] = ' ' then
for i:= 2 to length(s1) do
s:=s+s1[i]
else
for i:= 1 to length(s1) do
s:=s+s1[i];
writeln(s);
end.
- 08.04.2016 03:45
- thumb_up 49
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.