Вопрос по информатике:
Программа на С++
1. Написать программу вывода чисел от a до b (a и b вводит пользователь) с шагом в 1.
2. Вывести их произведение и сумму.
- 18.09.2018 08:51
- Информатика
- remove_red_eye 3524
- thumb_up 21
Ответы и объяснения 1
#include
using namespace std;
int main()
{
int a, b;
cout <> a;
cout <> b;
for (int i=a; i<=b; i++) {
cout << i << " ";
}
return 0;
}
Пример:
a = 5
b = 12
5 6 7 8 9 10 11 12
2.
#include
using namespace std;
int main()
{
int a, b, s=0;
long long p=1;
cout <> a;
cout <> b;
for (int i=a; i<=b; i++) {
p = p*i;
s = s+i;
}
cout << "p = " << p << " s = " << s;
return 0;
}
Пример:
a = 5
b = 12
p = 19958400 s = 68
- 19.09.2018 22:23
- thumb_up 32
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.