Вопрос по информатике:
Pasсal ABC.net
Помогите,пожалуйста
Даны два натуральных числа n и m. Составить программу, которая находит первое число в интервале [n; m] с наибольшим количеством делителей.
- 20.06.2018 10:31
- Информатика
- remove_red_eye 13915
- thumb_up 39
Ответы и объяснения 1
n,m,d,k,Max,Maxk:integer;
Begin
Write('n = ');ReadLn(n);
Write('m = ');ReadLn(m);
Maxk:=0;
For n:= m downto n do
Begin
if n>1 then k:=2
else k:=1;
d:=n div 2;
While d>1 do
Begin
if n mod d = 0 then k:=k+1;
d:=d-1
End;
if k>=Maxk then
Begin
Maxk:=k;
Max:=n;
End;
End;
WriteLn('Искомое число: ',Max);
WriteLn('Количество делителей этого числа: ',Maxk);
End.
- 21.06.2018 14:02
- thumb_up 47
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.