Вопрос по информатике:
Даны два действительных числа Составьте программу которая меньшее из них занимает их полусуммой а большее произведением.
- 23.03.2015 07:33
- Информатика
- remove_red_eye 2440
- thumb_up 51
Ответы и объяснения 1
int main() {
double a, b, t;
std::cin >> a >> b;
if( a > b) {
t = a;
a = a * b;
b = (t + b) / 2;
} else {
t = a;
a = (a + b) / 2;
b = t * b;
}
std::cout << a << " " << b << std::endl;
}
- 24.03.2015 15:48
- thumb_up 2
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.