Вопрос по информатике:
В С++ Составить программу нахождения числа строк матрицы А(6,6), максимальный элемент которых больше Р
- 24.12.2017 13:21
- Информатика
- remove_red_eye 10995
- thumb_up 37
Ответы и объяснения 1
using namespace std;
int main() {
const int S = 6;
int matrix[S][S];
cout << "Введите матрицу построчно, разделяя пробелами: " << endl;
for (int i = 0; i < S; i++) {
for (int j = 0; j < S; j++) {
cin >> matrix[i][j];
}
cout << endl;
}
int p;
cout << "p = ";
cin >> p;
int count = 0, max;
for (int i = 0; i < S; i++) {
max = matrix[i][0];
for (int j = 1; j < S; j++) {
if (matrix[i][j] > max) max = matrix[i][j];
}
if (max > p) count++;
}
cout << endl << "Ответ: " << count;
return 0;
}
- 25.12.2017 23:18
- thumb_up 39
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.