Вопрос по информатике:
1. Составить программу вычисления 2-ой, 3-ей и 4-ой степени числа A и возвращения этих степеней в переменных B, C, D. Разработать процедуру, для которой A — это входной параметр; B, C, D — это выходные параметры. Выполнить вычисления для 10-ти разных чисел. Результаты выдать на экран в программе в виде таблицы:
A B C D
НУЖНА ПОМОЩЬ В ПАСКАЛЕ(нужна программа)
- 08.09.2017 02:23
- Информатика
- remove_red_eye 4779
- thumb_up 31
Ответы и объяснения 1
Begin
B:=A*A;
C:=B*A;
D:=C*A;
End;
Var
A,B,C,D:real;
Begin
Write('A = ');ReadLn(A);
ABCD(A,B,C,D);
WriteLn(A,' ',B,' ',C,' ',D);
End.
Пример вычислений для 10-ти разных чисел:
A = 1
1 1 1 1
A = 2
2 4 8 16
A = 3
3 9 27 81
A = -10
-10 100 -1000 10000
A = 3.141592
3.141592 9.869600294464 31.0062573282858 97.4090099724839
A = 111
111 12321 1367631 151807041
A = 6.66
6.66 44.3556 295.408296 1967.41925136
A = -2.718121812
-2.718121812 7.38818618487016 -20.0819900202127 54.5852951023063
A = 789456123
789456123 6.23240970142191E+17 4.92021399983213E+26 3.8842930686378E+35
A = 123456789
123456789 1.52415787501905E+16 1.88167637178915E+24 2.32305722798259E+32
- 09.09.2017 14:19
- thumb_up 24
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.