Вопрос по информатике:
Составить программу для нахождения НОД десяти двухзначных чисел. Паскаль.
- 22.05.2018 00:47
- Информатика
- remove_red_eye 9202
- thumb_up 32
Ответы и объяснения 1
// Внимание! Если программа не работает, обновите версию!
function gcd(a,b:integer):integer; // НОД
begin
while b0 do begin a:=a mod b; Swap(a,b) end;
Result:=a
end;
begin
var a:=ReadArrInteger('Введите 10 натуральных двухзначных чисел:',10);
var g:=gcd(a[0],a[1]);
for var i:=2 to 9 do g:=gcd(g,a[i]);
Writeln('НОД=',g)
end.
Пример
Введите 10 натуральных двухзначных чисел: 38 42 56 82 96 32 18 40 58 90
НОД=2
- 23.05.2018 15:13
- thumb_up 48
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.