Вопрос по информатике:
Даны значения массива {аi}, i = 0, ..., 10 и переменной х. Составьте программу вычисления алгебраического многочлена 10-й степени по формуле Горнера: a10x10 + а9х9 + ... + а1х + а0 = ((...(а10х + а9)х + а8)х + ... + а1)х + а0.
- 24.12.2017 16:27
- Информатика
- remove_red_eye 9893
- thumb_up 24
Ответы и объяснения 1
// Внимание! Если программа не работает, обновите версию!
function Horner(Self:sequence of real;x:real):real; extensionmethod;
begin
Result:=Self.Aggregate(0.0,(p,q)->p*x+q) // коэфф. по убыванию степеней!
end;
begin
var x:=ReadReal('Укажите значение х:');
Writeln('Введите коэффициенты в порядке возрастания степеней: ');
Writeln('Результат: ',ReadArrReal(11).Reverse.Horner(x));
end.
- 25.12.2017 20:30
- thumb_up 44
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.