Вопрос по информатике:
Составьте программу одномерного массива (10 ячеек), с помощью генератора случайных чисел (диапазон от -500 до 500). Найти минимальное и максимальное, значение всего массива, найти сумму всех двузначных положительных чисел.
Очень срочно!!!!!!!!!!!
- 08.07.2017 00:38
- Информатика
- remove_red_eye 16856
- thumb_up 25
Ответы и объяснения 1
// Внимание! Если программа не работает, обновите версию!
begin
var a:=ArrRandom(10,-500,500); a.Println;
Writeln('min=',a.Min,', max=',a.Max,', Sп=',
a.Where(x->x in [10..99]).Sum)
end.
Пример
475 186 243 323 -497 23 -65 -2 180 74
min=-497, max=475, Sп=97
- 09.07.2017 04:38
- thumb_up 40
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.