Вопрос по информатике:
PASCAL ABC
БЕЗ RANDOM И ВСЯКИХ CRT
1) Вводится строка, состоящая только из строчных латинских букв. Найти какая буква в строке встречается максимальное количество раз.
Формат ввода
Строка s
Формат вывода
Буква и количество раз, которое эта буква встречается в строке.
Примеры: kfjgnsljgnljgvnjabgahsgkfbjhfdbshjbfajhbcbaue выводит j - 7
2) Напишите программу, которая находит в массиве максимальную последовательность убывающих элементов
Формат ввода
Первая строка содержит размер массива N. Во второй строке через пробел задаются N чисел – элементы массива. Гарантируется, что 1 < N ≤ 10000. Элементы массива - целые числа, не превышающие по модулю 1000
Формат вывода
Одно число: максимальное количество убывающих элементов
Пример: 5 и 1 2 3 4 5 вывод 0
5 и 1 3 2 1 4 вывод 3
- 10.07.2015 18:44
- Информатика
- remove_red_eye 2193
- thumb_up 22
Ответы и объяснения 2
b: array[1..10000] of integer;
s: string;
i,mx,tek,ind,n: integer;
begin
// задание 1
write('строка: '); readln(s);
mx:=0; ind:=0;
for i:=1 to 255 do a[i]:=0;
for i:=1 to length(s) do
if s[i] in ['a'..'z'] then inc(a[ord(s[i])]);
for i:=ord('a') to ord('z') do if a[i]>mx then
begin
mx:=a[i];
ind:=i;
end;
writeln('наиболее часто встречается буква: ',chr(ind),' - ',mx);
// задание 2
write('N = '); readln(n);
mx:=0; tek:=0;
read(b[1]);
for i:=2 to n do
begin
read(b[i]);
if b[i]<=b[i-1] then inc(tek)
else
begin
if tek>mx then mx:=tek;
tek:=0;
end;
end;
if mx>0 then writeln(mx+1)
else writeln(0);
end.
- 11.07.2015 07:22
- thumb_up 6
S:string;
i,Max:integer;
j:char;
Begin
Read(S);
For i:= 1 to Length(S) do
C[S[i]]:=C[S[i]]+1;
Max:=C['a'];
For j:= 'b' to 'z' do
if Max
End.
Var
A:array[1..10000] of integer;
i,k,Max:integer;
Begin
ReadLn(i);
For i:= 1 to i do
Read(A[i]);
k:=0;
Max:=0;
For i:= 1 to i-1 do
if A[i]>A[i+1] then k:=k+1
else if k>Max then
Begin
Max:=k;
k:=0;
End;
if Max=0 then WriteLn(0)
else WriteLn(Max+1)
End.
- 13.07.2015 00:54
- thumb_up 27
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.