Вопрос по информатике:
Составить программу, которая заполняет одномерный массив из 20 элементов случайными целыми числами от 1 до 99, а затем определяет, сколько в массиве имеется простых чисел (простым числом называется такое, которое делится только на единицу или само на себя). Процесс определения того, является ли число простым, оформить в виде отдельной процедуры.
- 04.12.2017 07:59
- Информатика
- remove_red_eye 14754
- thumb_up 7
Ответы и объяснения 1
Var
K:real;
d:integer;
Begin
if A > 1 then
if (A = 2)or(A = 3) then p:=p+1
else
if A mod 2 0 then
Begin
K:=Sqrt(A);
d:=3;
While (d
if A mod d 0 then
Begin
p:=p+1;
Write('(простое)')
End
End;
End;
Const
N = 20;
Var
A:array[1..N] of integer;
i,k:integer;
Begin
Randomize;
k:=0;
Write('Исходный массив:');
For i:= 1 to N do
Begin
A[i]:=random(99)+1;
Write(' ',A[i]);
P(A[i],k);
End;
WriteLn;
WriteLn('Кол-во простых чисел в массиве: ',k);
End.
- 05.12.2017 20:59
- thumb_up 26
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.