Вопрос по информатике:
Помогите составить программу, которая по сумме цифр определит делится ли число на 3.....
- 10.09.2017 23:39
- Информатика
- remove_red_eye 1152
- thumb_up 18
Ответы и объяснения 1
var s:byte;
begin
s:=0;
while n>0 do
begin
s:=s+n mod 10;
n:=n div 10;
end;
if s mod 3=0 then Div3:=true
else Div3:=false;
end;
var a:longint;
begin
write('Введите a: ');
readln(a);
if Div3(a) then write('Число делится на 3')
else write('Число не делится на 3');
end.
- 11.09.2017 22:58
- thumb_up 20
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.