Вопрос по информатике:
Срочно помогите пожалуйста!!!!!!!!!!!!!!Умоляю!!!!!!!!!!!!
Девочки Лиза и Алиса - лучшие подруги. Девочки очень любят делать
бусы своими руками. Недавно Лиза сделала себе бусы из A бусинок, а Алиса
- из B бусинок.
Девочки хотят еще больше укрепить свою дружбу, для этого они
собираются сплести счастливые бусы в подарок друг другу. Бусы считаются
счастливыми, если количество бусинок в подаренных девочке бусах будет
кратно количеству бусинок в уже имеющихся у девочки бусах, но при этом
не равно нулю.
Лиза и Алиса купили упаковку из N бусинок. Помогите им узнать,
сколько есть способов разделить все эти N бусинок между девочками, чтобы
сплетенные для обеих девочек бусы были счастливыми.
Формат входных данных
На вход подаются три натуральных числа N, A и B.
Формат выходных данных
Должно быть выведено одно число - количество способов разделить
все N бусинок между девочками
- 10.12.2017 09:45
- Информатика
- remove_red_eye 17830
- thumb_up 31
Ответы и объяснения 1
var a,b,n:real;begin read(a,b,n); n:=n/(a+b); writeln(abs(n));end.
- 11.12.2017 01:43
- thumb_up 33
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.