Вопрос по информатике:
Напишите программу формирования и вывода массива размером 6x3, каждые три последовательных элемента в строке которого составлены по следующему правилу:
1-й — равен сумме текущих индексов, увеличенной в 10 раз;
2-й — равен целой части от деления случайного числа на сумму текущих индексов;
3-й — равен разности двух предыдущих элементов.
- 25.09.2018 15:10
- Информатика
- remove_red_eye 19570
- thumb_up 29
Ответы и объяснения 1
N = 6;
Var
A:array[1..N,1..3] of integer;
i:integer;
Begin
Randomize;
For i:= 1 to N do
Begin
A[i,1]:=i*10;
A[i,2]:=random(i*13) div (i+2);
A[i,3]:=A[i,2]-A[i,1];
WriteLn(A[i,1],' ',A[i,2],' ',A[i,3])
End;
End.
- 27.09.2018 00:31
- thumb_up 4
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.