Вопрос по информатике:
ОЧЕНЬ СРОЧНО!!!!! ДАМ 30 БАЛЛОВ!!! ЗАДАЧА В С++
В один из жарких летних дней младший отряд в лагере решил сделать пир по случаю выхода новой части «Звездных войн». Иван и Вася купили в буфете огромную упаковку чипсов. Взвешивание упаковки на весах показало, что ребята купили W килограмм чипсов. Поспешно прибежав в свою комнату, изнемогая от желания съесть зловредные чипсы, ребята начали делить приобретенную упаковку, однако перед ними встала нелегкая задача. Иван и Вася являются большими поклонниками четных чисел, поэтому хотят поделить упаковку так, чтобы каждому из них досталось именно четное число килограмм, при этом не обязательно, чтобы доли были равными по величине. Ребята очень сильно устали и хотят скорее приступить к трапезе, поэтому Вы должны подсказать им, удастся ли поделить упаковку чипсов, учитывая их пожелание.
Формат ввода
В первой и единственной строке входных данных записано целое число w (1 ≤ w ≤ 100) — вес купленной ребятами упаковки.
Формат вывода
Выведите YES, если ребята смогут поделить чипсы на две части, каждая из которых весит четное число килограмм, и NO в противном случае.
- 25.11.2017 06:13
- Информатика
- remove_red_eye 2094
- thumb_up 45
Ответы и объяснения 1
#include
using namespace std;
int main(){
#pragma waringn(disable:4996);
int a;
scanf("%d",&a);
if(a==2){
printf("NO");return 0;
}
if(a %2==0){
printf("YES");
}else{
printf("NO");
}
return 0;
}
- 26.11.2017 20:55
- thumb_up 48
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.