Вопрос по информатике:
Вычислить 10 элементов которые получены в результате вычисления арифметического выражения Y=sin(a)/b где b=0.6 принадлежит [-1.57;3] с шагом 0.25 Найти сумму положительных и количество отрицательных значений элементов.
Помогите срочно пожалуйста!!!
- 11.11.2017 00:10
- Информатика
- remove_red_eye 17058
- thumb_up 32
Ответы и объяснения 1
k:integer;
begin
s:=0;k:=0;
b:=0.6;
a:=-1.57;
while a<=3 do begin
y:=sin(a)/b;
writeln('y=',y);
if y>0 then s:=s+y;
if y<0 then k:=k+1;
a:=a+0.25;
end;
writeln(s);
writeln (k);
end.
- 12.11.2017 16:02
- thumb_up 16
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.