Вопрос по информатике:
ПОМОГИТЕ ПОЖАЛУЙСТА! ПАСКАЛЬ!
----------------------------------
Напишите программу, которая в последовательности натуральных чисел определяет сумму всех чисел, последняя цифра которых равна А и все число делится на В. Последовательность чисел заканчивается числом 0. Числа А и В вводятся до цикла.
(должен быть цикл while)
Трудности с пониманием предмета? Готовишься к экзаменам, ОГЭ или ЕГЭ?
Воспользуйся формой подбора репетитора и занимайся онлайн. Пробный урок - бесплатно!
- 13.01.2015 02:29
- Информатика
- remove_red_eye 14210
- thumb_up 12
Ответы и объяснения 1
a, b, num, sum: integer;
begin
readln(a, b);
readln(num);
while num 0 do
begin
if (num mod 10 = a) or (num mod b = 0) then
sum := sum + num;
readln(num);
end;
writeln(sum)
end.
- 14.01.2015 05:48
- thumb_up 33
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.