Вопрос по информатике:
Напишите программу, которая находит сумму двузначных нечётных чисел в последовательности целых чисел. Программа получает на вход це¬лые числа, количество введённых чисел неизвестно, последовательность чисел заканчивается числом 0 (0 — признак окончания ввода, не входит в последовательность). Количество чисел не превышает 1000. Введённые числа по модулю не превышают 30 000. Программа должна вывести одно число: сумму двузначных нечётных чисел в последовательности.
Входные данные: 11, 15, 30, 9, 0
Выходные данные: 26.
- 11.05.2018 01:02
- Информатика
- remove_red_eye 5378
- thumb_up 31
Ответы и объяснения 2
// PascalABC.NET 3.2, сборка 1417 от 28.03.2017
// Внимание! Если программа не работает, обновите версию!
begin
Writeln(ReadSeqIntegerWhile(n->n0)
.Where(n->n.IsOdd and (n>=10) and (n<=99)).Sum)
end.
- 12.05.2018 19:33
- thumb_up 18
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.