Вопрос по информатике:
Составить программу вычисления максимального и минимального элемента линейного массива состоящего из 14 случайных чисел, принадлежащих диапазону (0;90]
- 05.10.2017 01:38
- Информатика
- remove_red_eye 2498
- thumb_up 40
Ответы и объяснения 1
Const
N = 14;
Var
A:Array[1..N] of integer;
i,Max,Min:integer;
Begin
Randomize;
Write('Исходный массив:');
For i:= 1 to N do
Begin
A[i]:=random(90)+1;
Write(' ',A[i]);
End;
WriteLn;
Max:=1;
Min:=1;
For i:= 2 to N do
Begin
if A[i]>A[Max] then Max:=i;
if A[i] End;
WriteLn('Max(A) = A[',Max,'] = ',A[Max]);
WriteLn('Min(A) = A[',Min,'] = ',A[Min])
End.
Пример:
Исходный массив: 66 70 88 36 30 11 53 1 57 77 6 40 65 46
Max(A) = A[3] = 88
Min(A) = A[8] = 1
- 06.10.2017 12:03
- thumb_up 3
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.