Вопрос по информатике:
Помогите,пожалуйста, написать программу на Паскаль
Напиши программу ,которая вводит десять чисел в одномерный массив ,а затем складывает по модулю отдельно все положительные элементы этого массива ,отдельно отрицательные элементы и находит разницу между ними и выдает полученные на экран через файл
- 26.02.2018 10:47
- Информатика
- remove_red_eye 12000
- thumb_up 35
Ответы и объяснения 1
var i,sum,sum1:integer;
begin
for i:=1 to 10 do begin
writeln('Введите ',i,' элемент');
readln(arr[i]);
end;
sum:=0;
sum1:=0;
for i:=1 to 10 do begin
if (arr[i]>0) then begin
sum:= sum + arr[i];
end
else
if (arr[i]<0) then begin
sum1:= sum1 + arr[i];
end;
end;
writeln('Сумма положительных равна ',sum);
writeln('Сумма отрицательных равна ',sum1);
writeln('Разница равна ',sum-sum1);
end.
- 27.02.2018 03:41
- thumb_up 51
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.