Вопрос по информатике:
Составьте программу в Паскале для проверки утверждения: "Результатами вычислений по формуле х²+х+41 при 0<х<40 являются простые числа". Все результаты вывести на экран.
- 07.12.2017 13:51
- Информатика
- remove_red_eye 5785
- thumb_up 15
Ответы и объяснения 1
Begin
WriteLn('f(x) = x^2 +x +41');
p:=0;
For x:= 1 to 39 do
Begin
A:=x*x+x+41;
Write('f(',x,') = ',A);
d:=2;
k:=0;
While (A0)and(d Begin
if A mod d = 0 then k:=k+1;
d:=d+1
End;
if k = 0 then WriteLn(' - простое')
else
Begin
WriteLn(' - не является простым');
p:=1;
End
End;
if p = 0 then WriteLn('Все полученные числа - простые')
else WriteLn('Не все полученные числа являются простыми');
End.
- 08.12.2017 19:04
- thumb_up 32
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.