Вопрос по информатике:
Пожалуйста помогите!
Напишите программу, которая в последовательности целых чисел определяет число отрицательных трехзначных чисел, кратных 3 и оканчивающихся на 6.
программа должна вывести одно число - число отрицательное трехзначных чисел кратных 6 и оканчивающихся на 3.
Признаком конца ввода чисел - ввод 0.
Пример работы программы:
Входные данные Выходные данные
-186 1
-36
36
186
0
- 14.03.2018 01:19
- Информатика
- remove_red_eye 2075
- thumb_up 12
Ответы и объяснения 2
A,k:integer;
Begin
k:=0;
Read(A);
While A0 do
Begin
Read(A);
if (A-1000)and(A mod 3 = 0)and(A mod 10 = -6) then
k:=k+1;
End;
WriteLn(k);
End.
- 15.03.2018 15:13
- thumb_up 11
#include
using namespace std;
int main() {
int a, c = 0;
for(cin>>a; a!=0;
c+=(a<0 && !abs(a/1000) && abs(a/100) && !abs(a%3) && abs(a%10)==6),
cin >> a);
cout << c << endl;
- 16.03.2018 16:41
- thumb_up 18
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.