Вопрос по информатике:
Напишите пожалуйста программу на C ++
Напишите программу, которая в последовательности натуральных чисел определяет сумму чисел, оканчивающихся на 3. Программа получает на вход количество чисел в последовательности, а затем сами числа. В последовательности всегда имеется число, оканчивающееся на 3. Количество чисел не превышает 100. Введённые числа не превышают 300. Программа должна вывести одно число — сумму чисел, оканчивающихся на 3.
- 27.07.2018 04:21
- Информатика
- remove_red_eye 16711
- thumb_up 35
Ответы и объяснения 1
using namespace std;
int main() {
int s, t, res = 0;
cin >> s;
for (int i = 0; i < s; i++) {
cin >> t;
if (t % 10 == 3) res += t;
}
cout << res << endl;
return 0;
}
- 28.07.2018 17:19
- thumb_up 41
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.